User Tag List

Gracias Gracias:  0
Me agrada Me agrada:  0
Me desagrada Me desagrada:  0
Resultados 1 al 1 de 1

Tema: Configurar Backup Automático En RouterBoard MikroTik y Enviar Por Correo

  1. #1

    Fecha de ingreso
    17 Feb, 20
    Mensajes
    27
    Reconocimientos
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Configurar Backup Automático En RouterBoard MikroTik y Enviar Por Correo

    Configurar Envió Por Correo De Backup y Export Automático De RouterBoard MikroTik

    Es importante que nuestros equipos cuenten con un respaldo periódico en caso de que suceda algún improvisto y necesitemos montar las configuraciones nuevamente. Los equipos Mikrotik nos permiten crear un backup en automático y enviar lo por correo (Es necesario configurar el servidor smtp: http://foroisp.com/threads/55-Agrega...TP-en-MikroTik) por medio de la función de scheduler y la de script de conexión.


    Configurar Backup (script y scheduler)

    Un backup nos sirve principalmente para poder subir lo en un equipo y poder tener las misma configuraciones, por lo que se recomiendo trabajar por ejemplo cuando se remplaza un Rb con el mismo modelo. Otro ejemplo donde nos servirá realizar un backup, es cuando se reinicie un equipo a fabrica para depurarlo y se necesita volver a poner con las mismas configuraciones. En estos dos casos solo se subirá y cargara el archivo al router.

    1 Nos dirigimos a System->Script y damos en el botón con símbolo de "+" para que se nos desplegué una nueva pestaña donde podremos agregar nuestro script para poder hacer y mandar el backup por correo.

    Nombre:  scrit1.png
Visitas: 145
Tamaño: 43.0 KB

    2 En la pestaña que se desplego vamos a agregar el script que genera el backup del equipo y lo manda por correo electrónico, este script puede ser pegado como esta, únicamente hay que cambiar el correo destino y el password de nuestro backup. Es importante asignarle los permisos que se muestran en la siguiente imagen para que se pueda realizar el backup.

    Nombre:  backup-01.png
Visitas: 133
Tamaño: 29.2 KB

    Código:
    :log info "Iniciando Backup"
    :global fecha ([:pick [/system clock get date] 7 11] . [:pick [/system clock get date] 0 3] . [:pick [/system clock get date] 4 6]);
    :global backupfile ([/system identity get name] . "- $fecha" );
    /system backup save name=$backupfile password="CONTRASEÑA"
    :log info "Generando backup..."
    :delay 10s
    :log info "Enviando backup por email"
    /tool e-mail send to="CORREO" subject=([/system identity get name] . \
    "- $fecha" . " Backup") file=$backupfile
    :log info "Backup Finalizado"


    3 Abrir el panel de scheduler y dar en el boton con el simbolo de "+" para poder programar una tarea automática.
    Nombre:  scheduler.png
Visitas: 56
Tamaño: 42.0 KB

    4 En esta pestaña podremos configurar cuando, a que hora y cada cuando se va a ejecutar el backup.


    1. Name: Nombre con el que se identifica.
    2. Start Date: Dia que iniciara el backup.
    3. Start Time: Hora de inicio.
    4. Interval: Cada cuando se ejecutara.
    5. Policy: Permiso que se necesitan para ejecutar el scheduler
    6. On Event: Aqui se coloca el nombre del script que creamos para nuestro backup


    Nombre:  scheduler-b.png
Visitas: 52
Tamaño: 16.3 KB


    Comprobación

    Los archivos se estarán enviando al correo y en el router se marcara cuantas veces se a aplicado,

    Nombre:  prueba-b1.png
Visitas: 49
Tamaño: 8.2 KB

    Nombre:  prueba-b2.png
Visitas: 48
Tamaño: 15.0 KB


    Configurar Export (script y scheduler)

    Un export es un tipo de archivo para poder visualizar ciertas configuraciones del equipo ya que es un archivo tipo texto con las configuraciones del equipo. Este tipo de archivo nos sirve para poder sacar las configuraciones del equipo y poder copiar solo las configuraciones requeridas ya que este tipo e archivos es editable, lo que nos permite ajustar el export antes de subir el archivo.

    1 Nos dirigimos a System->Script y damos en el botón con símbolo de "+" para que se nos desplegué una nueva pestaña donde podremos agregar nuestro script para poder hacer y mandar el export por correo.

    Nombre:  scrit1.png
Visitas: 145
Tamaño: 43.0 KB


    2 En la pestaña que se desplego vamos a agregar el script que genera el export del equipo y lo manda por correo electrónico, este script puede ser pegado como esta, únicamente hay que cambiar el correo destino. Es importante asignarle los permisos que se muestran en la siguiente imagen para que se pueda realizar el export.

    Nombre:  export-2.png
Visitas: 56
Tamaño: 26.6 KB

    Código:
    /export file=([/system identity get name] . "-" . \
    [:pick [/system clock get date] 7 11] . [:pick [/system clock get date] 0 3] . [:pick [/system clock get date] 4 6]); \
    /tool e-mail send to="CORREO" subject=([/system identity get name] . " Export  " . \
    [/system clock get date]) file=([/system identity get name] . "-" . [:pick [/system clock get date] 7 11] . \
    [:pick [/system clock get date] 0 3] . [:pick [/system clock get date] 4 6] . ".rsc"); :delay 10; \
    /file rem [/file find name=([/system identity get name] . "-" . [:pick [/system clock get date] 7 11] . \
    [:pick [/system clock get date] 0 3] . [:pick [/system clock get date] 4 6] . ".rsc")]; \
    :log info ("System Backup emailed at " . [/sys cl get time] . " " . [/sys cl get date])

    3 Abrir el panel de scheduler y dar en el boton con el simbolo de "+" para poder programar una tarea automática.

    Nombre:  scheduler.png
Visitas: 56
Tamaño: 42.0 KB

    4 Configuramos cada cuando se va a mandar a aplicar el script para enviar el export por correo.


    1. Name: Nombre con el que se identifica.
    2. Start Date: Dia que iniciara el backup.
    3. Start Time: Hora de inicio.
    4. Interval: Cada cuando se ejecutara.
    5. Policy: Permiso que se necesitan para ejecutar el scheduler
    6. On Event: Aqui se coloca el nombre del script que creamos para nuestro export.


    Nombre:  scheduler-e.png
Visitas: 56
Tamaño: 17.9 KB

    Comprobación

    Los archivos se estarán enviando al correo y en el router se marcara cuantas veces se a aplicado,

    Nombre:  prueba-e1.png
Visitas: 47
Tamaño: 8.4 KB

    Nombre:  prueba-e2.png
Visitas: 44
Tamaño: 17.5 KB
    Última edición por Saul.Herrera; 09/07/2021 a las 14:00

Permisos de publicación

  • No puedes crear nuevos temas
  • No puedes responder temas
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •